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Built in Source Code Control – Save as Server Project 

Creating a server project 

The first step in creating a server project in MotionWorks IEC Pro is selecting which third party Source Code 

Control (SCC) system to choose.   

To use this feature, click Project -> Select SCC system…, select “MotionWorks IEC Pro multi user file system” 

and click OK. 

 

  
 

 

 

Once the SCC has been selected, create the server project by clicking Project -> Save as server project.  First 

you will be prompted to Log on.  Enter an appropriate User name (this is used by the source control system to 

determine who is editing the server project) and click OK.  
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After a User name has been selected, a window will open prompting to select the path where the server project 

will be saved (the current project path is automatically entered as the “Client project” in the Save As server project 

window).  After selecting the appropriate path, click OK.  This will save a copy of the current project to the server 

folder specified as a server project.  This will also modify the current project to be a client project connected to 

the newly created server project. 

 

 

Creating a client project 

Once the server project has been created, other users can create client projects also clicking Project -> Create 

client project.  Selecting this will prompt the user to select a User name and Log on.  

 

 
 

 

After clicking OK, the user will be asked to select the path to the existing server project and a path for the client 

project.  After selecting the appropriate paths and clicking OK, a copy of the server project selected will be placed 

in the selected client folder and the client project will be opened. 
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Editing the project 

A server side project cannot be opened in MotionWorks IEC Pro and the only way to edit the project is through a 

client project.  When first opening a client project, all of the items in the Project Tree Window will be “read-only” 

which prevents any changes to the project.  To edit a POU or Data Type worksheet it must be checked out.  To 

do this, right click on the desired POU or worksheet and select “Check out”.  This will remove the read-only lock, 

add a small red check mark next to the POU, and allow edits to the checked out portion of the project. 
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When a POU or Data Type file has been checked out, other users are not allowed to check out the same portion 

of the project and a message alerting them to who is currently editing the POU will be displayed. 

 

 
 

When editing a POU and a new global variable is added, the compile error “No matching global variable” may 

result.  

 

 
 

To fix this error, right click on the Resource folder and check it out. This will allow Global variables to be added. 
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Once the Resource folder is checked out, right click on resource again and select Create Global Variables from 

Externals (once new global variables are added this operation cannot be undone by selecting Undo check out). 

After this is completed the project should compile without the missing global variable error. Check the Resource 

back in so the updated global variables get propagated to other users.  To avoid this error, check out the 

Resource folder before adding any Global variables.  
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Once editing is complete, either update the server project or discard the changes and revert to the state before 

check out by right clicking on the POU and selecting either Check in or Undo check out.  

 

 
 

Selecting Undo check out will bring up the window shown below. To proceed with undoing the updates, click Yes.  
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If another user has made updates to a POU and checked it back into the server project, to update your client 

project to match the server project, right click on the POU that was updated and select Get latest version. 

(Checking out a POU will automatically get the latest version).  

 

 

 

 

 

To update all POUs at once you can right click on the Logical POUs folder and select Update structure. This will 

bring up the Update structure window.  In this window, select “Get latest version” and click OK. (The same 

process works for updating data types) 
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To add a new POU to the server project, first create a new POU in the client project.  When the new POU is 

created an icon next will appear next to the POU to indicate that it is not included in the server project (as pictured 

below).  To add the POU to the server project, right click and select Insert to server project. 
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After the new POU has been added to the server project, other users can update this new POU into their client 

project.  To do this, the other users must right click on the Logical POUs folder and select Update structure… 

which will display the Update structure window. (The same process applies for adding Libraries and Data Types.) 

 

 

In the Update structure window, select “Add nodes to client project” and click OK.  This will add any newly 

created POUs (or libraries/data types) to the client project so that it will match the server project. 

 

 

 

To remove a POU from the server project, simply right click and select Delete from server project. (The same 

method applies for Data types) 
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Editing Hardware Configuration and Tasks 

To edit the Hardware Configuration, manage tasks, or edit global variables check out the Resource folder.  Note: 

for Hardware Configuration changes to take effect, the Hardware Configuration must be saved before checking 

the Resource folder back in).  Note: because the Hardware Configuration is a separate program operating 

outside of the MotionWorks IEC Source Control, it is possible to edit the configuration without checking out the 

Resource folder and these changes will only be made locally and will not update the server project. 
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Managing Libraries 

To add and remove libraries from the server project, simply check out the Libraries folder, edit, and then check 

back in.  Since a library is saved only as a path to MotionWorks IEC project, managing libraries on a server 

project can become tricky. 

 

There are a few different methods that can be used to manage libraries for a server project; the recommended 

methods are listed below with some pros and cons for each method. 

1. Save all libraries on the server. 

 Pros   

o Every user references the same library. 

o If a library is edited, updates will take effect immediately for all users. 

 Cons 

o If disconnected from the server, compiling the project will result in a library not found 

error until the library path is updated. 

o Multiple users could potentially edit the same library. 

2. Create a separate server project for each library and use a local reference to the client copy of the 

library. 

 Pros 

o Can disconnect from server and still compile the project. 

o Will block multiple users from editing the same library. 

 Cons 

o Users must manage and verify that all client library projects are up to date   

o All client libraries must be stored in the local directory for each user.    (It is 

recommended to use the default MotionWorks IEC Pro library folder: 

C:\Users\Public\Documents\MotionWorks IEC 2 Pro\Libraries ) 

3. Each user has an identical copy of the libraries stored on their local disk with the same path to the 

library (It is recommended to use the default MotionWorks IEC 2 Pro library folder: 

C:\Users\Public\Documents\MotionWorks IEC 2 Pro\Libraries ) 

 Pros 

o Can disconnect from server and still compile project. 

o Updating libraries will take less time than option #2 (must be manually managed 

though.) 
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 Cons 

o Updates to libraries must be manually managed. 

o If one user doesn’t have a library that is included in the server project, they will be 

unable to compile the project without first removing the library from the project 

 

 

Going Offline 

When not connected to the server, the client project can still be opened but the tools to interact with the server 

project will be unavailable (i.e. check in/out, Get latest version… etc).  To make edits to the project offline, the 

user must right click on the POU (or worksheet/folder) and select Properties.  In this menu, click the Attributes 

tab and un-check the Read only box and click OK.  Once the Read only setting is removed, the POU (or 

worksheet/folder) will be unlocked and free to edit.  

 

 

When changes are made offline, it requires a few additional steps to update the server project since the node was 

never checked out from the server project.  

1. Re‐name the POU(s) that were update to avoid conflicts with existing POU(s) on the server project. 

(Right click on POU, select Properties to edit POU name) 

2. Insert renamed POU(s) to server project.    (Right click on POU, select Insert to server project.) 

3. Remove old POU(s) from server project. (Right click on POU, select Delete from server project.) 
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4. Check out the renamed POU that was added.   

5. Right click on the POU and select Properties. 

6. Change re‐named POU back to the original name and click Apply or OK. 

7. When prompted to Rename node in server project, click Yes. 

 

8. After the POU has been re‐named, check POU back in and the server project will be updated. 
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Other tools available 

If it is impractical to use a server and a source code control system to manager project, MotionWorks IEC Pro has 

other useful tools to help manage projects that multiple users are working on.   
 

Sealing a project 

Sealed projects are useful when multiple users must open a project for debugging purposes and don’t want 

accidentally make any changes.  For more information on how to seal/unseal a project, see the 

Sealing/Unsealing a project FAQ on the Yaskawa website (FAQ# MTN‐998QUZ). 

 

IEC 61131-3 extended import/export 

The import/export feature in MotionWorks IEC is useful when making changes to individual POUs or Data type 

worksheets that must be transferred to other users/projects. 

To export all POUs or Data Types, select either the Data Types or Logical POUs folder inside the Project Tree 

window (1 & 2).  To export a single POU or Data type worksheet, select and individual POU or Data type 

worksheet (3). 

 

1.  2. 3.  

 

 

After the desired POU/Data type file(s) have been selected, click File -> Export… which will open the 

Import/Export window.  

 



 

 

Subject: Application Note Product: MotionWorks IEC Pro Doc#:  AN.MWIEC.02 

Title:  Multi – User MotionWorks IEC Project Management 

 

 

18                                   December 18, 2013 

 

Select “Extended IEC 61131-3 Export” and click OK. 

 

 

Select the folder to export the selected POU(s)/Data Type worksheet(s) to and click OK. 

 

 

To import a POU or Data Type worksheet that has been exported, select the Project folder in the Project Tree 

Window.  Once selected, click File -> Import.  Again select “Extended IEC 61131-3 Export” and click OK. 
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This will open the Object types window. Select the appropriate option and click OK. 

 

Clicking OK will open the Extended IEC 61131-3 Import window.  Navigate through the directories in the left half 

of the window and selected the folder containing the exported POU(s)/Data Types.  When the correct folder is 

selected, the right half of the window we be populated with all available POU(s)/Data Type worksheets that can be 

imported.  Select the desired items to import and select OK.  
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If the POU/Data type work sheet already exists in the project, the user will be prompted if they wish to overwrite 

the current version with the imported version. 

 

 


